The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 192 - File: inc/class_parser.php PHP 7.2.22 (Linux)
File Line Function
/inc/class_parser.php 192 errorHandler->error
/inc/functions_post.php 716 postParser->parse_message
/showthread.php 1057 build_postbit
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 192 - File: inc/class_parser.php PHP 7.2.22 (Linux)
File Line Function
/inc/class_parser.php 192 errorHandler->error
/inc/functions_post.php 716 postParser->parse_message
/showthread.php 1057 build_postbit
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 192 - File: inc/class_parser.php PHP 7.2.22 (Linux)
File Line Function
/inc/class_parser.php 192 errorHandler->error
/inc/functions_post.php 716 postParser->parse_message
/showthread.php 1057 build_postbit
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 192 - File: inc/class_parser.php PHP 7.2.22 (Linux)
File Line Function
/inc/class_parser.php 192 errorHandler->error
/inc/functions_post.php 716 postParser->parse_message
/showthread.php 1057 build_postbit
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 192 - File: inc/class_parser.php PHP 7.2.22 (Linux)
File Line Function
/inc/class_parser.php 192 errorHandler->error
/inc/functions_post.php 716 postParser->parse_message
/showthread.php 1057 build_postbit
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 192 - File: inc/class_parser.php PHP 7.2.22 (Linux)
File Line Function
/inc/class_parser.php 192 errorHandler->error
/inc/functions_post.php 716 postParser->parse_message
/showthread.php 1057 build_postbit
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 192 - File: inc/class_parser.php PHP 7.2.22 (Linux)
File Line Function
/inc/class_parser.php 192 errorHandler->error
/inc/functions_post.php 716 postParser->parse_message
/showthread.php 1057 build_postbit




Need "Nuke all spammer content"
#1
Some spambots have made a mess of things recently and I managed to ban them but the old "delete all spammer content" button has seemed to have disappeared.

As such I am unable to really clean everything up without spending a couple hours individually deleting each offending post.

I will spend some time doing this, but it's going to take awhile. Please be patient.

---------Addendum------------

Well, that actually only took about an hour and 15 minutes but was still a massive PITA. I didn't count all the posts I deleted but it was about 100. The return of the magic button would be greatly celebrated be me.
Reply
[+] 1 user Likes Tob's post
#2
We appreciate all your effort, Tob! Big Grin
Reply
#3
(08-06-2017, 10:22 AM)ableman33 Wrote: We appreciate all your effort, Tob!  Big Grin


And I appreciate the return of the Magic Button!  Just in time too; another spammer showed up in the last 10 min and I gave him the BOOT!


ALL SPAM WILL DIE!!!!  This I swear!
Reply
[+] 1 user Likes Tob's post
#4
Thanks Tob. REALLY: thanks. Smile

For future reference though:

If something is a pain in the butt to deal with: please contact me about it.

It's totally by chance that I wandered in here and spotted this within hours of it happening. It could have been days, weeks, or never, before I became aware. Having become aware I used my super-admin powers (underpants on the outside stuff) to zap 50 or so posts in a couple of minutes. Further to this I have changed the "human test" on the registration screens from what is probably the stock question for a myBB forum (and therefore easy for a bot to be programmed to bypass), of "What is 2x2?", to "In what year was TerraGenesis created?"

I have no knowledge of the "magic button" to which you refer i.e. where it was and why/when it disappeared. However maybe the above sees an end to the spambots anyway. If not, let me know, and I'll perhaps change the question to something even harder to answer. Harder... unless you happened to have actually read some stuff on the site that you supposedly want to register to. Creation year... it's right there on the site home page. Wink
Reply
#5
(08-07-2017, 03:06 PM)AndySlater Wrote: If something is a pain in the butt to deal with: please contact me about it.

Well, oddly enough, I did consider contacting you but after weighing various options I decided not to do so under my "don't hassle The Man" doctrine. Just because I figured this wasn't a Super Duper Emergency and could wait until you got around to it.

AndySlater Wrote:I have no knowledge of the "magic button" to which you refer i.e. where it was and why/when it disappeared.

Interesting, and on that note I should probably mention that this happened once before, over a year ago in similar circumstances. A bot was spamming during one of my routine checks. I logged in to kill it, but when I did so the 'purge spammer' options were not available to me. I manually banned the bot and cleared out the crap, then emailed Melly about it and mentioned the 'purge spammer' option was missing. She then logged in to check, found it in place, and responded back to me that nothing was gone/unusual. When I logged in again, the 'purge' option was back. I had no explanation.

This time around, I just figured that the purge option might have been some of your personal code and that maybe it just hadn't been "transfered over" during the move. Or that maybe you were restructuring things and it got lost in the shuffle, et cetera.

As such, if you haven't been jockeying code, I can't imagine why this would happen. My only 'theory' (read: pulling guesses out of my...hat) might be something along the lines of not being able to zap bots when they're in the act, or some other bizarre mis-timing type deal. And even that theory doesn't hold a lot of water. Or possibly my permissions were changed or unreadable or who knows what. Hmm.

As of this writing, the original 3 spambots are still pounding on the door. I just checked the Member List.

Most interesting. I'll keep my eyes open and if it happens again I'll logout/re-login and see if that doesn't help. perhaps after waiting a few minutes.

With your new precautions, this all may be moot.
Reply
#6
It may be advantageous to enable the hidden captcha and possibly add reCaptcha to the signup process.

Both can be enabled via the Admin CP, but recaptcha requires signing up with Google (which is free).
Reply
#7
Sorry got the delay in replying to this. I had set to receive notifications of replies to the topic... but I haven't had any notifications. Sad

I'm up to my ears in something right now and only called in as the result of an email from ableman33. I'll put this on my list to look at some more as soon as I can.
Reply


Forum Jump: